CVE-2026-123023
HIGH
NVD
CVSS Score
7.3
Severity
HIGH
Published
Nov 05, 2026
Vendor
unknown
Description
A flaw has been found in agentscope-ai AgentScope up to 2.0.8. This affects the function check_permissions of the file src/agentscope/tool/_builtin/_bash.py of the component Bash Tool. This manipulation causes incorrect authorization. Remote exploitation of the attack is possible. The exploit has been published and may be used. Upgrading to version 2.0.9 mitigates this issue. Patch name: 6b43b13a46401e86abd3defeed9a8bfe5b37bc6d. It is recommended to upgrade the affected component.
References
- https://github.com/agentscope-ai/agentscope/
- https://github.com/agentscope-ai/agentscope/commit/6b43b13a46401e86abd3defeed9a8bfe5b37bc6d
- https://github.com/agentscope-ai/agentscope/issues/3313
- https://github.com/agentscope-ai/agentscope/pull/2629
- https://github.com/agentscope-ai/agentscope/releases/tag/v2.0.9